思科路由器模拟器

思科路由器模拟器 思科模拟器独臂路由该怎么设置?

思科模拟器独臂路由该怎么设置?

思科模拟器独臂路由该怎么设置?

https://baike.so.com/doc/6569653-6783415.html 这是360搜索的单臂路由词条

单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或\

思科模拟器独臂路由该怎么设置?

网络架构规划

如图所示,网络出口使用路由器或者防火墙实现nat地址转换,下联核心交换机,实现流量汇聚,再部署接入交换机,实现用户接入即可。500人规模,建议通过vlan技术隔离广播域,使用较多的是根据楼层或者部门划分vlan。

用户网关直接指向路由器,路由器与下联交换机通过单臂路由互联。

单臂路由配置

router(config)#interface fastethernet 0/0

router(config-if)#no shutdown #激活物理接口fa0/0

router(config)#interface fastethernet 0/0.1 #进入fa0/0.1虚拟子接口

router(config-subif)#encapsulation dot1q 10 #将虚拟子接口fa0/0.1划分到vlan 10并封装格式为802.1q

router(config-subif)#ip address 192.168.10.1 255.255.255.0 #设置ip地址及子网掩码

router(config)#interface fastethernet 0/0.2 #进入fa0/0.2虚拟子接口

router(config-subif)#encapsulation dot1q 20 #将虚拟子接口fa0/0.2划分到vlan 20并封装格式为802.1q

router(config-subif)#ip address 192.168.20.1 255.255.255.0 #设置ip地址及子网掩码

# 默认路由和nat配置同前面50人规模基本一样,此处贴上命令。

int f0/0 #出接口配置地址(向运营商申请的地址是202.1.1.1/24)

ip address 202.1.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 202.1.1.2 #默认路由器,把出口访问流量都扔给运营商(运营商对端地址为202.1.1.2)

access-list 1 permit 192.168.1.0 0.0.0.255 #匹配内网用户流量

ip nat inside source list 1 interface fastethernet1/0 overload #将内网用户流量在出口做nat,转换成接口f0/0地址访问互联网(关键字overload)

interface f0/0

ip nat outside #nat的外侧接口

int vlan 1

ip nat inside #nat的内侧接口(一定要注意,是svi接口)

二层交换机配置

vlan配置(sw1配置举例)

vlan 10

vlan 20

interface f1/1 #下行接口

switch mode access

switch access vlan 10

interface f1/2 #下行接口

switch mode access

switch access vlan 10

interface f1/3 #下行接口

switch mode access

switch access vlan 20

interface f1/4 #上行接口

switch mode trunk

switch trunk allowed vlan all

如果出口不是路由器,而是防火墙,配置如下:

如果网络出口为防火墙,而不是路由器,一般可以图形化配置(其实路由器也可以图形化配置,过程基本类似),配置步骤:

1、防火墙创建子接口ge0.10,并指定ip 地址,如下图:

2、防火墙创建子接口ge0.20,并指定ip地址,如下图: